TopoGun logo
Introduction
WelcomeLicense AgreementInstalling TopoGunInterfaceGetting StartedLoading Reference MeshesPlanning AheadCreating and Loading MeshesWorking with SymmetryCreating and Editing GeometryExporting Subdivision SurfacesBaking MapsUsing the Morpher feature
User Guide
Reference
TopoGun License Server

Getting Started

Loading Reference Meshes

A reference mesh is the 3D model we want to create a new topology for or bake maps (such as normal maps).

Reference meshes usually have very high polygon counts and are created in external 3D sculpting/scanning applications.

TopoGun supports a wide variety of 3D file formats. OBJ files can contain groups, and TopoGun will display them in the Scene View. In case you're using the FBX file format, it will be loaded as a single reference mesh and each object in the file will be loaded as a separate reference mesh group.

After we start TopoGun, the first step is to import one ore more reference meshes in the scene.

Click on Load Reference Mesh from the File menu to do that, for each reference mesh you want to bring into TopoGun.

Show Video

Once the reference meshes are loaded, they are listed in the Scene View. You can select each of them or select individual groups. There can be only one selected reference mesh/group at a time.

The groups are color coded and you can change their colors and show/hide them in the Scene View.

TopoGun scales and moves the meshes in such a way that the central reference mesh fits into an unit cube, for better navigation. You can set the central reference mesh in the Scene View.
Use the Frame All command from the View menu to reset the camera position and orientation on the central reference mesh.

You can select a reference mesh directly in the viewport, by left clicking on it and holding down the Ctrl + Shift keys. If the Alt key is pressed too, the group that was clicked on gets selected.

Use the Isolate Selected command from the View menu to hide everything in the scene, except for the selected reference mesh or group. The Show All command will unhide everything in the scene, while the Show All Groups command will unhide all the groups in the selected reference mesh, while leaving the other object's visibility unchanged.

Planning Ahead

It's always good practice to plan ahead the retopologized mesh edge flow. You can do that in TopoGun by using the Guide Lines tool.

Using the Guide Lines tool, you can draw strokes on the reference mesh, to establish the overall edge flow, as a guide when creating geometry.

If you want to have the strokes symmetrical, check the Enable Symmetry option from the Options menu. The Steady Mouse feature will help you create smoother lines, by averaging the mouse position as you draw.

Show Video

Creating and Loading Meshes

You can load an existing low poly mesh for editing with the Load Mesh command, from the File menu. Make sure you have the parent reference mesh selected beforehand.

Use the Delete Selected Object command to delete the mesh. It can also be used to delete reference meshes from the scene.

You can create a scene mesh from scratch, using the Create Mesh command, from the Mesh menu.

Show Video

Working with Symmetry

Most of TopoGun's features and tools support symmetry.

To activate the symmetry mode, click on Enable Symmetry, from the Options menu. The default shortcut is X.

Open the Symmetry Options panel from the View menu to choose the active symmetry plane or create and edit your own symmetry planes, with custom positions and orientations.

Creating and Editing Geometry

You can create geometry over the reference mesh, by using any one of Topogun's existing tools. This newly created mesh will be referred to as the retopologized mesh.

You can further modify the meshes via the features grouped in each object's Inspector View.

In order to activate a tool, click on the tool's icon in the Tools window. Each tool's options and parameters can be tweaked from within the Tool Options panel. For more in-depth information regarding the TopoGun tools, please consult the User Guide and Reference sections of this document.

  • Create is a tool used for directly creating geometry over the reference mesh.
  • Edit is used for operating simple modifications over the retopologized mesh, such as selecting and moving components, creating edge loops, collapsing edge rings, soft selection editing, symmetry options, and different marquee selection modes, etc.
  • Draw is used for creating geometry by drawing guide lines.
  • Bridge is used for creating edges and faces in between points. You can stitch together patches of differing geometry using this tool.
  • Slide is used to move the vertices on the selected edges accross the adjacent faces shared edges.
  • Tubes can be used to quickly retopologize tubular parts of the reference mesh.
  • Brush can be used to modify multiple scene vertices at once. You can move, select and relax the vertices by chosing one of the existing brush modes.
  • Extrude is used to extrude groups of border edges.
  • Slice is a tool used to quickly slice through the mesh, using an intersecting plane.
  • Cut is used to cut edges.
  • Circle is used to create circular mesh parts.
  • Shell is used to add thickness to mesh parts, such as clothing.
  • Patch is a complex tool, used to create mesh patches, with dynamic automatic topology.

Exporting Subdivision Surfaces

After creating your retopologized mesh, you can use the Subdivision feature to create a subdivision surface from the retopologized mesh. This will recreate the small details that were present in the reference mesh.

The Subdivision module not only makes a new more efficient subdivision mesh from the retopologized mesh, it also "wraps" the new subdivision mesh onto the reference mesh recovering it's high frequency details, such as skin pores, wrinkles, material patterns and so on.

The newly subdivided mesh is then ready to be exported to your sculpting application. You will then be able to recover the intermediate subdivision levels from within your sculpting application and further modify your newly created subdivision mesh. The Subdivision module has two predefined compatibility modes, one for ZBrush and one for Mudbox .

Baking Maps

You can bake normal, displacement, ambient occlusion, color, curvature, transmission and cavity maps using TopoGun.

There are a few important things to remember before baking your maps. It is important for the lowpoly cage (retopologized mesh) to have valid UVs. It must contain only quads and/or triangles.

Please note that once the lowpoly cage is loaded for the purpose of baking maps, you should only move it's vertices and edges around. Any changes to the actual topology, such as adding or deleting components, will lead to UV coordinates being deleted and as a result your baked maps will have artifacts in them.

Using the Morpher feature

There are situations when you need to modify the reference mesh vertices positions after you retopologized it (eg. when you create morph targets or blend shapes on the reference highpoly model, in very fine detail, or when a revision is required on the reference mesh).
In this case, you need to have the modifications done on the reference mesh transferred back to the retopologized mesh. To do that, you need to load the original scene and execute the Store Morph command from the Morpher menu. Then, load the new reference mesh, with the vertices positions moved, and execute the Apply Morph command.
The scene vertices should be moved accordingly to the new reference mesh.

© 2022 Pixelmachine LTD. All rights reserved.