TopoGun logo
Introduction
WelcomeLicense AgreementInstalling TopoGunInterfaceIntroductionOverviewDocking PanelsFullscreen ModePie MenuKeyboard ShortcutsPreferencesGetting Started
User Guide
Reference
TopoGun License Server

Interface

Introduction

TopoGun's interface is meant to be as simple to use as possible and it is highly customizable.

Move the mouse cursor over the following image to view the names of the main interface areas.

Overview

The Main Menu contains TopoGun's commands and options and it's organized by categories. All TopoGun commands and/or options are listed inside the Main Menu.

Each submenu in the Main Menu can be detached (teared off) and moved around, for easier later access.

Show Video

Toolbar

The Toolbar contains icon shortcut buttons to frequently used commands and features. Some of the buttons are always visible (for commonly used commands, such as file loading/saving or application state specific, like symmetry options, views toggle and so on).

The Toolbar is dynamic and context sensitive though. Depending on the type of the selected object, it shows buttons related to it, to reduce visual clutter.

Tool Selection Bar

The Tool Selection Bar is for setting the active tool. In TopoGun, tools help you modify the currently selected object.

There are two types of objects:

  • Reference Meshes, created in external applications, usually with a high polygon density and no optimized topology and edgeflow. These are the source meshes used for creating new topology and are always kept as separate files on disk (not included in the TopoGun scene).
  • Meshes can be imported or created/edited in TopoGun. They are the result of the retopology process and usually have a much lower polygon count than the reference meshes.

Just like the Toolbar, the Tool Selection Bar is dynamic and contextual: it lets you select only tools available for the currently selected object type.

Tool Options View

Here you have access to different parameters related to the currently selected tool.

Scene Statistics

The Scene Statistics area displays useful information about the selected object and the entire scene.

It is divided in three vertical sections:

  • The lower section displays information about all the meshes in the scene: the total number of vertices, edges, faces and triangles (the number of pure triangular faces and the number of total triangles you'd get if you triangulate all the meshes in the scene).
  • The middle section contains information about the loaded reference meshes: the total number of vertices and triangles.
  • The upper section contains statistics about the currently selected object only, such as name, type and some extra information:
    • If a reference mesh is selected, the number of vertices and the number of triangles is shown.
    • It the selected object is a mesh, the number of selected/total vertices, edges, faces and triangles is displayed.

Viewport

In this 3D view you can visualize the scene and interact with the objects via the available tools.

TopoGun supports two viewport mouse interaction models, which should be familiar to many 3D artists.

Industry Standard 1Industry Standard 2
RotateAlt + Left Mouse ButtonAlt + Middle Mouse Button
PanAlt + Middle Mouse ButtonShift + Middle Mouse Button
ZoomAlt + Right Mouse Button (or Mouse Wheel)Mouse Wheel

You can switch between the two interaction models in the Preferences window (available in the Edit menu).

Show Video

Camera Select

The viewport has several predefined cameras. Press the Camera Select button to switch between different views, such as the Perspective, Front, Top, Left etc.

Scene View

TopoGun supports multiple objects within the same scene. It can load multiple reference meshes and each reference mesh can contain retopology meshes. More on this later.

The Scene View contains an hierarchical list with all the objects in the scene.

Here you can set the active object, hide or show objects, change reference mesh colors and perform different commands on the selected object via the right click menu.

Inspector View

In the Inspector View you can change the selected object's properties, such as visibility, name, color, and specific properties, based on the object type (mesh or reference mesh).

In this view you also get access to each object's features dropdown panels.

Status Bar

The Status Bar displays brief descriptions about the controls the user moves the mouse cursor over.

When a time consuming task takes place, like loading a very dense reference mesh or using the automatic retopology feature, a progress bar is displayed inside the Status Bar.

Extra Views

TopoGun several extra views, not shown by default. Each one can be toggled from the View menu:

  • Bake Maps View is the interface to the maps baking feature. You can bake several types of maps in TopoGun, such as normals, displacement, color, ambient occlusion, curvature, transmission and cavity.
  • Log View shows the application log.
  • Symmetry Options View lets you tweak symmetry parameters. All the TopoGun tools support symmetry and here you can select the active symmetry plane and even create new symmetry planes, to better fit your reference meshes.
  • History View contains a list with all the commands and events that can be undone/redone with the Undo/Redo commands. Here you can easily step backward multiple steps.
  • Show keyboard And Mouse Input displays the keyboard/mouse events in real-time. It is useful when recording video content (such as tutorials).

Docking Panels

Almost all the panels (views) in TopoGun are docking panels. This means they can be moved freely on the screen or can be docked to the left/right sides of the main window.

They can be stacked vertically or horizontally and when they're not in a docking state, you can minimize them, so you get more working screen space.

In case you close any of them, you can bring it back from the View menu.

Show Video

Once you're happy with the panels placement, you can save the layout with the Save UI command in the Edit menu.

To reset the layout to default, click on Reset UI in the Edit menu.

Fullscreen Mode

Press the Tab key to switch between normal/fullscreen mode.

When in fullscreen mode, the status bar and all the panels are hidden.

To keep a panel visible when in fullscreen mode, right click on its title bar and enable the Visible In Fullscreen option.

In case you want to keep the toolbar visible in fullscreen, enable the Toolbar Visible In FullScreen option.

Show Video

Pie Menu

The Pie Menu is an on-screen multi level menu, accessible via the Space key.

It contains base commands, available any time (such as application level options), but also contextual items, based on the selected object's type and the active tool.

The lower part of the menu contains global commands, the middle part usually contains object related features and the upper parts contains items related to the active tool.

Show Video

Keyboard Shortcuts

You can change the shortcuts in the Keyboard Shortcuts window (from the Edit menu).

image

TopoGun has two kinds of keyboard shortcuts:

  • Global Shortcuts, accessible anytime the application is running.
  • Tools Shortcuts, defined for each tool and available only when the tool is active. Each tool has its own set of shortcuts and you can even set duplicate key combinations accross tools. They will not conflict, as only the active tool's shortcuts are enabled at a time.

To reset the shortcuts to their initial settings, click on the Restore Defaults button.

Preferences

You can open the Preferences window from the Edit menu.

General

The General tab contains application wide preferences, such as the number of undo levels, viewport navigation model and camera field of view. Disable Use Y As Up Axis in case you're working with meshes which use Z as the Up Axis.

image

Bake

Here you can set different mesh processing parameters used by the maps baking module.

image

© 2022 Pixelmachine LTD. All rights reserved.